millarworld.tv Comics Creators

Video games thread - "What are you playing?"


#3634

I’ve been playing the hell out of Grand Theft Auto Online. Hackers or no, that game is just… fun. They released a new content patch and one of the vehicles looks like Street Hawk, but flies like the motorcycle in Mega Force.

It’s a ridiculous machine, far and away more fun than their homage to Knight Rider’s KITT. I don’t have missiles yet. I’m working on it.


#3635

So Horizon Zero Dawn

This is a real mixed bag of a game.

Aesthetically, it is quite brilliant and a very good looking game indeed.

Story-telling? Pretty good. Game menus - seem to be OK, fairly standard but standard exists for a reason, no need to go re-inventing the wheel.

The one big flaw is the game asks you to save a tribe that treated you like shit for the entirety of your life and Aloy is apparently OK with this. There is no ‘go fuck yourselves’ dialogue option and there should have been. The only good development is a sicko called Bast got killed off, bye bye you psycho shitebag, no one misses you.

The problems? Ah, quite a few:

  • Potions - So I go to use a potion in the standard way, it’s displayed on the D-Pad right, so just hit that direction? No. Instead:

“Using items in Horizon Zero Dawn is actually incredibly easy. The d-pad is used to harbor all of your consumables. Up will allow you to use your medicine pouch, and right and left will cycle through the different items you can use. Then, once you’ve found the item you want to use, all you need to do is press down on the d-pad. After a short animation, Aloy should reap the rewards or be able to use items you’ve selected.”

  • Easy? Bullshit. At no point during the start did the game actually explain this quite crucial mechanism. This does continue the tendency of recent years to make games difficult by screwing around with healing mechanisms.
  • Changing weapons / grabbing loot: Someone had the idea that the action should not stop while you do this! Wonderful, whoever decided that, punch yourself in the balls.
  • Tagging a target: Makes bugger all difference, no the camera will not track it for you, then the point of it is?
  • The “aim”: Frankly, they’d have been better off not even offering aiming, just point and shoot and hope it hits because it probably won’t. There were times when I pulled incredibly good shots, while other times I’d have the target on a head-shot and the arrow goes way wide just because.
  • Stealth: Hugely variable and it seems to depend on whether the game decides you’ve been seen or not, with the long grasses being hugely variable in how far they extend.
  • Main quest: Anything involving the main quest will involve a combat sequence of total arse where you’re best to sling the difficulty down to easy and head butt them all to death.

Damage also varies greatly - I’ll shoot an entire piece off a robot and then shoot a human with fire arrow, setting him on fire and this has nowhere near the panic or indeed damage you would expect. Similarly I’ll be whacking a guy with the spear and there’s no recognition of pain or damage, which is kind of crap.

Due to this during the game I’ve either pulled off a superb array of silent strikes or bow shots, or I’ve resorted to just pounding the crap out of everything up close because there’s no point trying to be strategic about it. The problem being that I would have liked to have been! I would have liked to shoot them with arrows from on high but due to how unreliable the aim is that no longer works.

Pluses?

  • Doing the first Tallneck is superb.
  • When it works, the stealth takedowns are superb.
  • Robo-enemies are wonderfully designed and unique.
  • World aesthetics are excellent.
  • Story is good.

Maybe it’ll get better as it goes on, but after this first 6 hours I’m really uncertain due how badly they screwed the aiming, which is near enough the main mechanic for me right now. So I don’t know how far I’ll be able to get in this one due to cluster**** controls, which clearly require more dexterity than I have.

EDIT: All right enough of this shit, it’s getting sold. Why the fuck they spent a shitoad of time designing a game of robodinosaurs and then throw in a load of humans that are somehow far harder to deal with, I don’t know.

EDIT 2: That was fast, I have a sale. It’s also, thinking about it, has the same kind of flaws that killed the Tomb Raider reboot for me.

EDIT 3: As that sale just got a cancel request, I’m actually quite reluctant to give in completely on this, so maybe the solution is stuff the main plot and anything involving killing humans and just explore the world while killing robodinos? Hmm, perhaps.

EDIT 4 - 24hrs later:

OK, so tried the bandit camp again after last night’s rage-quit.

Ye gods, who came up with this? It was an exercise in tedium: Spot grey-black enemies on a grey-black background, with an aim that is at least 1/3 luck no matter what you do - yes, I pulled off a small amount of headshots but no one near what I should given I had the target on their head! Another time I shot a bandit in the head, with a fire arrow no less and it still took two more to kill him. Add in silent strike sequences where as you hit them the enemy is allowed to cry out and you can’t do anything about it, arbitrarily removing your stealth while still crouched because Super-Bandit has spotted you. Towards the end, I was searching for the last two and they apparently picked me up while being all the way at the top of a building on the other side of camp!

Despite it feeling like the bandit bastards had access to cloning, I kept killing them, more by silent strike in the grass than arrows, because the latter remains unreliable - also concentration needs to slow down time more, the amount of movement permitted is still a pain in the arse to deal with. So did finally get the camp, but if I compare this to taking out a Bandit Camp in Witcher 3, it’s no contest - W3 was far more thrilling.

Oh yeah, Nil - total idiot, I somehow got spotted so went and hid in the grass, what does he do? Stands up and gives away where we are! Bastard. I legged it and left the macho moron there, unfortunately he has Game Immortality perk active.

There needs to be a way to at least recon the camp without being spotted, so you have some idea where the cover grass spots are. Equally a Bandit level, so you’ve an idea of how many are left.

Still, let’s be more positive:

  • The opening sections are genius, the idea of playing Aloy as a kid then adult is extremely effective. Even the stealth quest with Teb was quite smart in how it taught you the core aspects of that.
  • The world design is incredible - I walked over a river, onto a pair of rusted car frames and then ran up a collapsed wall or stairway. Weather effects are well done, as is the day / night cycle.
  • Talking of Witcher 3, you can see the influence of that game to a degree on this.
  • The game only went downhill with the fight at the end of the Proving, that entire section was dreadful and that was where my opinion of it went way down - less humans, more robots!

#3636

As for Arkham, I am getting too old spending 3 hours being stuck at a point in a boss fight.

Why did I change the settings. Because I can! :smile:

…and it is only a game.

Cheers all…


#3637

I play a lot of games on easy these days. I’m not usually looking for challenging game play. For games where I really enjoy the combat system, I’ll up the difficulty level. But for most games I just want to have some fun beating up bad guys and whatnot.


#3638

This is exactly what my gaming experience has transitioned into. If I’m getting frustrated in combat, it’s time to turn down the difficulty. Enough shit pisses me off in life, I don’t need my stress relief to do it to because I want bragging rights that I’ll never use.


#3639

I play all of them on easy, not that I play that much but there’s a simple couple of reasons.

I buy games very cheap on Steam, I never spend more than $10, I have spent $1.85 on a game that people were raving about at $60 on PS4 within 8 months of that release.

I like the story progression most of all, I don’t want to replay the same bit 30 times. To be fair there has to be an element of challenge or there’s no point but a bit is fine for me.


#3640

This is a big part of why I find in-person RPGs infinitely better than computer games. If a player screws up in my game, he doesn’t reload and try again. His actions have consequences that ripple on for years to come.

If a game lets you do the hard bits over and over until you get the outcome you want, I’m not convinced it’s technically a “game” any more, I think it’s better classified as a “puzzle”. It’s got more in common with a Rubiks Cube than with the RPGs I play.


#3641

I know what you mean. I went down the same snake three times in a row, but then I managed to get onto a ladder that took me way up past it.

‘Game’ indeed.


#3642

I finished Fire Emblem Echoes last night. Finally. I’ve felt like I’ve been in the final stretch of the game for ages now. I’ve enjoyed it, but it just kept going and I’ve got that “I want to play something else itch”. After defeating the (seemingly) evil ruler of the invading country, I thought all that would be left is to defeat the evil priest behind everything. What I wasn’t factoring in was having to do another dungeon crawl, kill a possessed noble, do some single character trials and then the hardest final battle I’ve ever seen in a Fire Emblem or probably in any game.

The two armies are finally combined, but split across a map of narrow passages. One side is hounded by a high level mounted knight and two high level Dread Fighters, which are sword-fighters practically immune to magic and very hard to hit. The other side is deep within a sea of moderately high level multiplying creatures, being spawned by said evil priest. He’s powerful enough to one hit kill most player characters and can nullify 3 of every 4 attacks against him. Beyond him are two high level witches, who continually spawn more moderate level witches, another evil priest with a high range attack that reduces anyone it hits to 1 hp. Behind them is the final boss, a dragon whose HP is expressed as ?? (it’s actually about 100, which is double the highest other level in the game). The dragon periodically uses an earthquake attack which hits everyone across the map, he can counter any attack with a move that can one hit KO most characters but has a low hit rate, thankfully. He’s got a huge attack range and when you do finally get him down to about half HP, he switches to a mode that nullifies any attack made against him save for the main character’s new magic sword and still OHKOs but with a higher accuracy. Oh and he heals 5 hp every turn, except for when he’s in the low health mode, when he heals 40 hp every turn.
And half the map is made of poison tiles that you can’t move through at full speed and deal 5hp damage a turn.

So it’s a pretty gruelling battle and takes ages. I got to within spitting distance of winning when Alm, the main character, got killed, causing a game over. Two and a half hours later, I managed to win through (the trick is to use an attack that deals high damage when the enemy’s on the cusp of going into the low health mode, so that Alm can kill him in one attack). I basked in the end credits, the slightly disappointing Animal House style “here’s what happened to everyone” thing and then… it went back to the world map for a new chapter. It actually looks pretty fun (a cross-over into the kingdom from the original Fire Emblem) but… yeah, I thought I was done.


#3643

:dizzy_face: That sounds pretty ridiculous.
I’ve found that there’s a fine line between thrilling and horrifying when it comes to levels in Fire Emblem. That one would probably give me some sort of trauma.


#3644

It reminded me of the finale in Fire Emblem 7, the first one I played, where you’ve got a dragon that takes up four squares and can attack at a range of about up to 3 or 5 squares, forcing you to do continual hit and run raids. The first time I did it, I’d used an action replay to cheat mercilessly, but I replayed the whole game properly a year or two back and it was pretty tough. I lost a few characters doing it, but couldn’t be arsed to reset.
Awakening and Fates are much easier by comparison, as you can grind to your heart’s content beforehand (you can grind in Echoes too, but it’s less convenient largely). I can’t even remember Sacred Stones, Shadow Dragon and Mystery of the Emblem’s final bosses.


#3645

Just got massively hacked off with Steep - sure, it’s a Hard challenge but how about making it so the hard part isn’t due to the damn camera and incline angle you make it look like, you know so I can see where I’m going? And get rid of those other players, all they are are distinctions, scrap 'em.

Still, made it to Level 29, final level of 30 is in sight.


#3646

Having wrapped up dishonoured 2, which was thoroughly OK, I have moved on to rise of the tomb raider.
I really like it, but also really liked the first. The graphics and asthetics work better for me than the u charted games, as does the combat. I’ve taken the plunge and gone for hard mode, as I tend to find third person shooter a fairly easy once I get going.


#3647

Horizon Zero Dawn - Short version: It didn’t go well…

Tried two of the hunt trials - conclusion of each was I wanted to feed that hunter to his own campfire!

Those trials went and magnified all the flaws of the game - that the ‘stealth’ is tall grass or nothing, that the ‘aim’, even with Concentration +, is still a matter of luck - to the degree they should bother supplying a target, just shoot and hope it hits. Strategy is pretty much ‘strike from tall grass, don’t get detected or and we will randomly remove your crouch status in tall grass as we like’. The logpile one was exasperating due to the aim being so crap and that it took about 3 arrows to loose it! By that time the grazers were gone - it was an exercise in frustration, as was the canisters one - I’d have a good line on 4-6 canisters, I’d be lucky to get two!

Nor does it really feel like an RPG, but more an action game trying to be one - so it has levels and upgrades, but they have little impact, you can’t just go and buy better gear as you would in RPGs. Oh it offer other weaponry, but I’ve found no difference - a sharpshoot bow will still be subject to the same aim flaws as the normal bow so the point is?

There are a load of potentially interesting abilities that might improve it, though after the disappointment that was Concentration +, I’m sceptical I’ll grind to get them, as they’re so locked away.

And as for the camera, let’s aim there, no, there’s suddenly a fern in my way. As soon as you attack a robot, the camera goes mad and goes all over the place, anywhere but showing you the enemy you’re engaging.

If anything this is starting to make Mass Effect: Andromeda look good and the combat there is rubbish too.


#3648

Yikes, I really value your opinion and was looking forward to HZD.


#3649

Bear in mind my 3d spatial ability is lousy, so you might get on better with it than I have. (I really need a minimap display in games like this and it doesn’t have one.)

There’s times when it’s brilliant then others where it goes right to the other pole, ME:A does that too but the difficulty is much lower. Guerilla have, unfortunately, stuck to their Killzone tendency where ‘Easy’ isn’t easy. Now to a degree that’s fine but it would have been better for the game to be a bit honest about that. I haven’t died much, but have had hard hits and suspect taking out the bigger creatures will probably be beyond me.

What hacks me off the most is the aim for the bow, it’s massively erratic, even with the slow-time ability maxed out, but is the one thing you need to rely on.

It does look lovely and killing the things is satisfying but their lack of experience with this type of game is telling after about 10 hours.

EDIT: Hmm, been going around the net, might have found an explanation of how the aiming actually works. If it does, it’s not one the game ever made clear, but could change things for the better.

EDIT 2: Holy hell, that does make a difference - well, on the robo enemies at least. I managed to have several arrows go exactly where I wanted them to, including learning how to explode blaze canisters - which was awesome.

Also ended taking on and taking out another Sawtooth of all enemies, which was also impressive.

Right then, there’s this graphic effect that tells you when your bow hits max accuracy but it’s quite subtle and easy to miss, especially if you’re fighting in a downpour. The good news is that this works far faster than you think, but you still have to train your trigger finder not to fire immediately which is a bit counter-intuitive.

Still, the session just now saw me kill a load of Striders, multiple Grazers via igniting the Blaze canisters, some watchers and that Sawtooth. That was pretty awesome.

Dunno how it’ll work on humes but you never know.


#3650

So I’m a few hours deep into Fire Emblem Echoes’ post game. It’s very much an escalating scale of masochism gameplay wise, as you go across the water to Archanea and then crawl yet another dungeon. I got to the seventh or eighth floor (of ten, it seems) before bailing and I think I’m done. It’s really combat for combat’s sake, with thin story. I was hoping the trip to Archanea would touch on the stories of the Archanean members of Alm and Celica’s army or offer a gratuitous appearance from Marth and co, but seemingly not. It’s just an opportunity to grind and get high level weapons for the sake of it, which isn’t that interesting.


#3651

Today’s exploits in HZD:

Alternating between pissed off and happy in taking down Sawtooths: One I managed to do by blowing up its guts - near enough literally as it has a Blaze canister there. The other two were harder and far more irritating, wish the game would draw out a bit more in these battles. On the other hand, the new dodge move I have is quite cool.

Say hello to Lancehorn, Redeye Watcher, Longleg and Stalker - new enemies. The first two are upgraded Grazer and Watcher respectively, another is avian and the last has a stealth field and runs around crapping out proximity mines! Oh yeah, that guy was fun.

Aloy also got ambushed by a pack of Bandits, what followed was not pretty… For them.

Killing Grazers en masse by blowing up a Blaze canister on one is becoming a guilty pleasure and I really want to do the same to the Lancehorns but I need to get Freeze arrows.

Even after playing a while, the game still has the ability to be jaw-dropping in its graphics.

Currently working out how to use tripwires and traps on Sawtooths, with mixed success. The game is rock hard, so if you remember playing Killzone 2 on ‘easy’ then yeah, it’s like that. Working out the aiming has transformed how I’m playing it too, have been able to be far smarter.

Oh and my Aloy tends to go for cut-you-off-at-the-knees sarcasm in dealing with arseholes.

EDIT: Oh, forgot to say: If you are lucky enough to have ignited the blaze canister so as to blow the Sawtooth’s guts out and balls off, the boom is quite a bit bigger than that which you get from Grazers. (Did set fire to a Grazer and manage to get far enough away from it before it blew despite it chasing me.)


#3652

Today’s exploits can be summarised as: Sawtooths, Shell-Walkers and Fire Bellowbacks - oh my!

Wow. Worked out that I actually do have Tearblast arrows, so hit a Sawtooth’s belly with one, then evaded them up close - with the pair going through the tall grass I was in - waited for them to go off, went and ignited the blaze canister on the one I hit with a Tearblast arrow, the resulting boom near-killed it and took the other down to 50% health. After that I quickly killed the weak one and went straight at the other one - and somehow won.

Despite misreading the arrow symbol, thought it was Tearblast, it’s actually Precision, I did manage to - just about - take out a Fire Bellowback I do not recommend how I did it, certainly not against a pair either! That’d be pretty much a recipe for instant death.

Shell-Walkers - damn I want Freeze arrows, why can’t I have them yet? This was an utter scrap from start to finish, no grace or strategy to it - just Aloy pounding the crap out of 'em.

Also found a new Corrupted zone that had a Level 23 Corrupted Fire Bellowback - er, OK, bye bye! Found a ton of campfires. Took out a couple of Corrupted Watchers then some Cultists turned up, then noticed one of them was dumb enough to be wearing a Blaze canister! One BBQ later and his mates turn up, I stay hidden until they turn and kill one from behind while his mates walk off.

By now Aloy is utterly loaded with resources and shards, so crafted a load of Fast Travel packs and warped to Mother’s Crown to buy Tearblast arrows.

Also on exploration found I was able to go around adversaries by using mountains and valleys which was a nice touch, especially as there was no cover for taking on a Sawtooth.

One other thing I don’t think I’ve addressed yet is the whole Matriarchal society. Apparently, this aspect has led to much controversy, with some fools seeing it as some sort of assault on their manhood. What it actually is? It does depict a Matriarchal society, but it’s not anywhere near a perfect one. You can see why it runs the way it does, the laws it set up, but there’s points to be critical of too, it’s a surprisingly subtle piece of work, especially for the conceptual minefield it’s in.

Finally, some of the shots I’m pulling off now are truly excellent.

EDIT: Talking of shots, forgot to mention one of the very cool aspects. The Focus shows you info on the enemy and weak spots, but it also briefly locks onto those weak spots for you! So, if you do it quick enough, you can line up a perfect shot exactly where it needs to go, via quickly flicking from Focus to lock-on to bow then aim and fire.


#3653

So, had quite mini-session tonight:

Turns out it takes 3 Precision arrows to blow the crap out of a Fire Bellowback’s cargo sac, taking it down to just under 50%, a silent strike and couple of heavy attacks then finishes the job. This is only good for a solo Bellowback, for a pair it’d be better to try and ignite the sacs and use those to kill both.

Had a major hunting run - killing fox, raccoon, turkey and rabbit with a surprising amount of ease using the Focus trick. Result is 4 upgrades are now maxed out and the massive supply of wood I had has gone up in smoke so I can start grabbing everything in sight again.