millarworld.tv Comics Creators

Video games thread - "What are you playing?"


#3214

It looks like I’ll end up tackling automaton before the others anyhow as it’s quicker to download


#3215

Heheheh - that is what deters me from going digital.

Download size - 50GB.

Er, yeah, that’ll take, er, 2-3 days if I’m lucky.

Government invests in high-speed internet infrastructure? Hahahah, oh, you were serious? We, er, we don’t do that over here.


#3216

Yeah. There are clear practical hurdles to a digital-only market. It’ll happen eventually but it’ll be when we have perfected self-driving cars


#3217

So had 2 goes on Zelda:

Part 1: Access Death Mountain

I now have flamebreaker armour, upgraded to Fireproof status which makes whacking Red Lizalfos so very fun. I have one breathing fore at me to no effect! Fireproof, bro!

Got a few more shrines and of yes, Igneo Talus - bastards. Still taken a few of those out but what an evil idea.

The Goron minecarts are nuts, but excellent.

Part 2: Board Vah Rudania

Groan, so far it’s 2 for 2 for these ‘board the beast’ sequences being bloody irritating. This one involves a bastard fusion of stealth and escort mission, so yeah, I’m going to love this. Suffice to say, the stinking bastard piece o’ piss is done and I’ve the fast travel point on the beast active.


#3218

So, somehow, with a whole lot of swearing involved, managed to do the Vah Rudania dungeon: Exasperating, irritating, nowhere near as much fun as some fuckwit thought, with a map that’s completely fucking useless and an overall experience that is the polar opposite of the rest of the game. The rest of the game, outside of these goddamn beasts, is more freeform, but in these things? There is only the way the game wants you to do things. Also, on this one rotating the beast, when it’s on a lava field, makes no damn sense at all, at least the other one was just moving a trunk up and down.

So the Ganon fight? Far easier, I immediately handed him his arse so in order to do me damage he had to pull out an invincible shield out of his arse. Invincible shield meet internet, meet solution of bomb - which didn’t work for me at all, ice arrows were the logical solution as he was Fireblight Ganon, but no. Anyway, got past that and, despite him resorting to cheap shit like flying outside of the arena shooting fireballs, fucker got hit by a load of ice arrows - game over, man, game over.

The cutscenes that followed were well-done but couldn’t erase the sense that the entire experience in getting to them was pretty much rubbish. I’m now certain the other two beasts will be similar exercises in frustration.


#3219

Did you like the game or not Ben?

It sounds like you found it to be a mixed experience, like me.


#3220

I’ve decided that, because Zelda is so massive, I’m going to break my cardinal rule and have two games on the go. So I’ve started Sword of Mana on the GBA.

It’s fun broadly. Combat is a bit “mash A to win” but there’s a bit of nuance in swapping weapons and magic. There’s a nice item upgrade system that’s gradually revealing itself too. It’s a remake of an original GameBoy game and I can’t imagine how it worked on that.

I did have an ObiWomble moment with it this afternoon though. Reached a new town and what I’d term as the end of the first act of the story, as the two protagonists meet the people they’ve been looking for. The game then grinds to a barely interactive halt for about forty minutes of plot exposition (and the plot isn’t that compelling, especially due to the pedestrian dialogue - the main antagonist is called “Dark Lord” for instance). Got through all that, was allowed to play again - very quickly got killed by an over-powered enemy, forced to reload my save from before all the exposition.

I went thru it again this evening and just continually tapping A to get thru dialogue took 25 minutes. Turns out there is a save point after, but it’s in one of four directions you can go in and the game gives no nudge towards it.


#3221

In a great many respects I love a lot about the game, off the top of my head:

  • Cooking is fun
  • Armour upgrades are quite smart and there’s an actual substantive difference before and after
  • Armour set bonuses are great - Fireblight Ganon trying to set me on fire for instance, fireproof bro.
  • The aesthetic of the world is incredibly good, with subtle regional differences that help you navigate
  • Map that includes relief info is revolutionary
  • Some of the shrines are actually logical puzzles
  • Weapon system I quite enjoy, most of the time.
  • Environmental interaction is off-the-scale, but can be inconsistent in presentation/indication

There’s probably more as I’ve racked up 50-60 hours, probably more - that doesn’t happen on a rubbish game. However, it seems for anything main quest related, all that goes out the window and a crappy, mandatory sequence or two come along that are nowhere near as good as its designers clearly thought it was.

I consider ‘eclipse’ to be the perfect term for these sequences for relative to the size of the game and its other accomplishments, their relationship is akin to that of moon and sun, thus the one far smaller body completely obscures the far larger for a time. Then you get past the Sequence of Total Arse, go back to doing other stuff like the Tarrey Town sidequest and the game’s back to its usual, far better self.

EDIT: Also, the idea that the beasts have 5 control terminals then a master one is perfectly fine. It’s when you start trying to get to them and they’re in the most fucked-up locations and/or angles imaginable that the plot point collapses - it’s a perfect example of a plot vs game conflict going. I’ll get the first one or two fine, but after that it goes into the realm of vidgame logic aka Buy The Guide (or cheat via the Internet).

Thing is I get irritated if I have to resort to internet answers, I like to be able to work stuff out myself but often in these puzzles it’ll be something with little indication of my being able to do that or just out right counter-intuitive, which I’ll never come up with e.g. A Shrine had a metal block in a wall, but they painted it to look like a wall block, not the metal effect. What they were going for is you should be trying everything, by using Magnesis you’d find the block, if you were looking the right way. What that misses is that I will only use Magnesis if I have reason to and, until now, every metal block had that particular appearance thus I had no reason to suspect there would be an invisible metal block in the wall.

EDIT 2: Also, on the list of things the game excels at - thunderstorms. No game has them anywhere near as scary as this.


#3222

:laughing: This is hilarious, where other sites would use the terms “rage quit”, “gamer rage”, MillarWorld now has “Obiwomble moment”

I like this.

Master of trades and dealer of bargains? Certainly! Video games? Not so much.

(Though, the Yakuza Kiwami PS4 game is up for pre-order for £29.99 at Amazon)


#3223

Lately playing just Simcity on the tablet. But I get to play the old Halo because my nephew is now old enough to play. Timeless, that first game. :slight_smile:


#3224

Which version? I recently played the remastered Anniversary edition on Xbox One but I think the original on the original Xbox is just as good.


#3225

So, just had a major, unexpected success on Zelda - I took out the Yiga Clan!

Why unexpected? Well, the sequence in the hideout is that you have to get to the centre without being spotted, combined with some guards possessing one-hit kill ability. Yep, not a good combination for me.

Now I did decide to cheat to the max on this, text walkthrough, vid walkthrough, oh yes, preparation was Batman-level.

Turned out to be far more straight-forward than expected, managed to lure the guard in each of the two rooms - shorter than I expected really - got through the doors and got to the boss fight.

Master Kolga is a boss fight, but it was clearly one they decided to play for laughs, especially the final cutscene which renders him less master ninja and more Wile E Coyote with a scheme gone wrong.

Got another shrine that was very good until the final section where you have to throw an ice block through flames. Now that’s utterly unfair because the game establishes the opposite elements are very destructive to each other. You stab an Ice Lizalfos with a firespear and it’s a one-hit kill! So, you can see why I’m not inclined to throw an ice block through fire.

Still, got it, another spirit orb, done over 70 shrines and racked up just over 80 hours!

Was kind of fun on the road to the Yiga hideout, got ambushed by three teleporting assassins, so had to throw a bomb, detonated, they were stunned then died.


#3226

That Yiga boss fight is hilarious. I wasn’t thrilled at the prospect of a stealth section and first tried to just fight through it. Unfortunately, the large guards just one hit kill you (even with Mipha’s Grace and fairies on hand), which is a shame.


#3227

So I plowed through the Fallout 4 DLC - I have to say, it adds quit a bit to the game and I mostly enjoyed it.

Far Harbor is the most substantive and prettiest, which takes place on a mist-soaked island. It didn’t suck me in as much as many reviewers, because I just wasn’t at all involved in the competing philosophies of the three groups (Children, Synths, Harbourmen) - it was okay, with a weird mine-crafty type interlude.

Automatron is shorter but quite fun, and having a robot companion is way more fun then it initially seems. Before long you have a beast of a walking-tank following you, which, aside from some pathfinding issues in corridors, can make combat a fairly tireless affair. The quest itself is quite fun and ends with a sort of rift on the Superhero genre.

Vault-Tec is basically just a bunch of quests about building vaults. There’s one or two substantive bits of play in here, and a couple of interesting fights as you dig through the tunnels. It’s only really interesting because it sheds some light on the machiavellian nature of the overseers. The settlement building stuff doesn’t interest me.

Nuka-World is something I actually really enjoyed, aside from middling reviews. It’s by far and away the most difficult, and visiting areas of the park proves quite a unique experience. The downside for most players is it forces you to be the boss of a group of raiders, but this didn’t bother me because, for the most part, it all takes place in it’s own microcosm. There’s a part near the end where you take your activities further afield, and that seems to be the crossing the line for some, but I just did it for the gameplay really.

Ended up at lvl 50 with a whole lot of critical hit perks and weapon/armour modding perks, which has made the game quite fun. There isn’t much left for me to in terms of the meat of the game, but there’s tons and tons of sidequests. If I ever revisit it, that is.

In other news: Zelda has arrived! After a quick update and about 20 minutes of play I can say this: My god, do you notice the drop in resolution between playing PS4Pro and the Switch on a 4K TV.


#3228

I’ve had a frustrating morning.

I bought a SNES multi-tap (an adapter that lets you add a third and fourth controller for compatible games) a few weeks back but haven’t been able to test it, as I’ve only got two pads and I’ve not been able to get together with my SNES owning friends to try theirs.

This morning I got a Japanese SNES controller I’d ordered off eBay. Great, I’ll test that and the multitap, I thought.

First problem is that it turns out not all PAL SNESes are able to use Japanese SNES controllers, there was a running change (to either add or remove compatibility, I’m not sure) and mine’s on the wrong side of it. So it only works when plugged into the multitap, which bridges the region issues. Unfortunately, the actual controller doesn’t work properly (dodgy D pad, unresponsive other buttons), all of which took a long while to work out, not least when I plugged it into port 2 of the SNES and tried it on Smash Tennis, which came up with a warning not to put a multitap in port 1, for some reason.

This was exacerbated by the multitap, it appears, not actually working as a multitap. It has a switch that moves between “2 player” mode (which seems like a largely useless mode to have) and multi. Regardless of which mode it’s switched to, the only controller it’ll let work with the console is player 2 and not the third and fourth player ports that is its sole reason for existence.

So instead of a multitap to use with a third controller, I have a partially defective Japanese controller I can only use at all through a mostly defective multitap. Yay.


#3229

Is anyone playing the new Guardians of the Galaxy game? I’m not a big fan of Telltale—I did enjoy the first two chapters of Fables but then I totally forgot about it—but I’m intrigued by this one.


#3230

I seem to have a syncing problem with my joycons.

Sometimes the left controller de-syncs and sometimes the right controller doesn’t respond.

I’m not sure what to do save for sending it in to repair, which would take a fortnight, or buying a new controller.


#3231

My only Telltale game was the first Walking Dead game. I really enjoyed it, but felt a little disappointed when I realized that the basic framework of the story is the same no matter how you play it. It’s the illusion of choice, which made me feel a little cheated.


#3232

I’ve heard similar lukewarm reports about the Batman game. From what I gather, these are fairly talky games without a huge amount of action, which maybe works better for some properties than for others.

Having said that, the team dynamic of GotG should offer some fun opportunities for character interactions, you would think.


#3233

Coming back to this - nostalgia probably dictates my number one pick more than it should do (1 and 2 are pretty much on a par), but I’d go with this:

  1. Fourth generation: Megadrive/Genesis, SNES
  2. Sixth generation: Dreamcast, PS2, GameCube
  3. Seventh generation: PS3, Wii
  4. Eighth generation: PS4, XB1
  5. Third generation: NES, Master System
  6. Fifth generation: Playstation 1, Saturn, N64

(My gaming experience doesn’t go back far enough to cover first or second generation stuff.)